LWJGL
September 01, 2014, 13:58:04 *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: LWJGL 2.9.1 released!
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: [Bug report] Keyboad input not working without a graphical primitive  (Read 2864 times)
Qudus
Talks Too Much
***
Posts: 123


« on: March 24, 2007, 16:01:22 »

Hi,

There's a bug in the 1.0 release of LWJGL. While Mouse input is working properly Keyboard input (BUFFERED) does not produce any "events" when no graphical primitives are being rendered. From the moment I add the first primitive, the input is working again.

Of course this is low prio, since any game has graph prims Wink.

Marvin
Logged
Matzon
Administrator
Demigod
*****
Posts: 2242



« Reply #1 on: March 24, 2007, 16:37:49 »

do you have a test case ??

Are you sure you're not talking about the need to call Display.update ?
Logged

Qudus
Talks Too Much
***
Posts: 123


« Reply #2 on: March 24, 2007, 16:56:02 »

Are you sure you're not talking about the need to call Display.update ?

Exactly this was the problem. Thank you very much. And sorry for the false alarm.

Marvin
Logged
Matzon
Administrator
Demigod
*****
Posts: 2242



« Reply #3 on: March 24, 2007, 23:35:44 »

np.

The problem is that we don't process input before display.update (unless you manually call poll). Not sure why mouse works then Roll Eyes
Logged

elias
Nerdus Imperius
*****
Posts: 899



WWW
« Reply #4 on: March 25, 2007, 03:06:27 »

It works because we poll the directinput mouse state directly, bypassing the message loop.

 - elias
Logged

Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines
SMFAds for Free Forums
Valid XHTML 1.0! Valid CSS!